水仙花数
(编程题须知) (参考答案)
时间限制:C/C++语言 2000MS;其他语言 4000MS
内存限制:C/C++语言 32768KB;其他语言 557056KB
题目描述:
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
现在要求输出所有在m和n范围内的水仙花数。
输入
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
输出
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。
样例输入
100 120
300 380
样例输出
no
370 371
下面是我的答案,如果你有更好的解决方案,请在下面评论哦,大家一起交流学习!
import java.util.ArrayList;
import java.util.Scanner;
public class Test {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
ArrayList value = new ArrayList();
while (scanner.hasNext()) {
String string = scanner.nextLine();
// exit
if (string == "q" || !string.contains(" ")) {
break;
}
value.add(string);
}
for (String s : value) {
System.out.println(solution(Integer.parseInt(s.split(" ")[0]), Integer.parseInt(s.split(" ")[1])));
}
}
public static String solution(int m, int n) {
String result = "";
if (m > 99 && n < 1000) {
while (m <= n) {
if (m == Math.pow(m / 100, 3) + Math.pow(m % 100 / 10, 3) + Math.pow(m % 10, 3)) {
result += m + " ";
}
m++;
}
}
return result == "" ? "no" : result;
}
}